Data delay due to Infrastructure Outage

Incident Report for YCharts

Monitoring

Stock, fund, index, and model portfolio data has been fully processed and we are actively monitoring.

Please note that some non-performance data points may still appear off and these will be resolved over the weekend. We will provide a final update once everything is confirmed stable.
Posted May 08, 2026 - 15:57 EDT

Update

We are making progress in resolving last night's infrastructure outage.

- Stock, fund, and index performance data has been fully restored.
- Portfolio performance calculations are currently in progress and will need a few more hours to complete.
- Please note that some non-performance data points may appear off today and these will all be resolved over the weekend.

For the latest updates, please return to status.ycharts.com. We appreciate your patience.

YCharts
Posted May 08, 2026 - 11:19 EDT

Update

UPDATE 9:52 AM:
- All Stock, Fund and Index performance data has been fully restored.
- We have calculated ~30% of portfolios.
- Email reports will be sent once portfolios are fully complete.

We experienced a data delay due to an infrastructure outage that occurred last night. As a result, new data, including pricing, was not imported overnight.

We apologize for the inconvenience and appreciate your patience.

YCharts Team
Posted May 08, 2026 - 11:07 EDT

Identified

We experienced a data delay due to an infrastructure outage that occurred last night. As a result, new data, including May 7th pricing, was not imported overnight.

We are actively working to restore this data and process calculations. We do not have an ETA at this time, but will continue to post updates as they become available.

We apologize for the inconvenience and appreciate your patience.

YCharts Team
Posted May 08, 2026 - 08:55 EDT
This incident affects: YCharts Application.