Issues affecting Excel Add-In
Incident Report for YCharts
Resolved
The issue has been resolved. On some Windows machines, local DNS caching is causing an issue with Excel connectivity. To fix this please uninstall and re-install the excel add-in. You will not lose any work or progress while doing so.

Please see instructions for details: https://www.loom.com/share/2e7062ad1520470bbe4d1d4ce42fb534

We sincerely apologize for causing a disruption in your day.
Posted Jul 27, 2021 - 07:59 EDT
Monitoring
A fix has been implemented and is live. We are monitoring any continuing issues related to excel connectivity.
Posted Jul 26, 2021 - 10:39 EDT
Identified
We have identified the DNS level issue causing larger requests from our Excel application to fail. We are implementing a fix and users should see this issue resolved in approximately 30 minutes.
Posted Jul 26, 2021 - 10:34 EDT
Investigating
We are currently investigating an issue that is impacting our Excel connectivity. This issue is affecting a small percentage of our clients and we are actively working to address the problem. Please follow our status page(https://status.ycharts.com/) to subscribe to our future updates. We sincerely apologize for the inconvenience and will post updates when we have an ETA on a solution.
Posted Jul 26, 2021 - 09:59 EDT
This incident affected: YCharts Application.