Issue affecting our Chat Software
Incident Report for YCharts
Resolved
The issue affecting our third-party chat software has been resolved and is fully functional.

We apologize for the inconvenience this may have caused you.
Posted Aug 27, 2024 - 11:57 EDT
Identified
We are experiencing an outage with our chat software. We are in touch with the provider and will provide periodic updates as soon as we receive them. Please email us at support@ycharts.com or ring us at (866) 965-7552.

We apologize for the inconvenience this causes you.
Posted Aug 27, 2024 - 10:50 EDT
This incident affected: YCharts Application.