Missing NAVs and prices for a subset of ETFs and Mutual Funds
Incident Report for YCharts
Resolved
We resolved the issue impacting end of day values and performance calculations for select Funds, including Model Portfolios that hold these securities.

We apologize for the inconvenience this caused you.

Best,
YCharts Team
Posted Feb 09, 2024 - 17:45 EST
Identified
The issue has been identified by our upstream data partner and we are working closely with them to backfill NAV and price data for those affected securities.

After we implement the fix, we will conduct rounds of testing and reviews. We do not have a timeline yet but we will continue to provide periodic updates.
Posted Feb 09, 2024 - 15:23 EST
Investigating
We are experiencing delays in updating the performance calculations for certain ETFs and Mutual Funds for 2/8/24, due to a late receipt of close prices and NAV from our data provider. This also affects Model Portfolios holding these Funds.

Our team is actively working on a resolution, and we will keep you informed on our progress. We apologize for any inconvenience this may cause and thank you for your patience. We will add another update when we have one.

Best,
YCharts Team
Posted Feb 09, 2024 - 10:11 EST
This incident affected: YCharts Application.